Plugin Developer Discussion

Discussion for FogBugz Plugin developers

FogBugz died after example plugins build, invalid.

After installing 7.0.6a I ran build.bat in the Plugins/examples directory as per normal, it seemed to run fine.

However, I then could not connect to my web server (which only runs FogBugz 7). So I got out my hammer and smacked that walnut hard (actually, just rebooted the machine).

FogBugz 7 was back up, but with one error:

Plugin "" failed during reflection - Hide Notification
6/18/2009 10:26 PM (GMT+01:00): Could not load file or assembly 'FogCreek.Plugins, Version=, Culture=neutral, PublicKeyToken=d8367ba9769b01ac' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) See the plugins page for more information.

Just for fun I rebuilt the examples again, Workflow was built successfully, and this time loaded OK.

I didn't notice any build errors the first time around, and the only thing that changed for the second build was that I'd rebooted the machine after FogBugz died post first examples build.

I had none of my own plugins loaded before or after upgrade.

Probably not a lot to help you here, just documenting the error, but if I can look anywhere for extra info that might help let me know.
Ian Jones Send private email
Thursday, June 18, 2009
That error is consistent with the Workflow plugin needing to be rebuilt to work with the latest version, though all the plugins would have shown that error if none of them got uploaded successfully.  It's perhaps meaningful that it's Workflow since it is alphabetically last and therefore built last and perhaps uploaded last.  What's less clear is whether something going wrong on your server caused the upload to fail, or the upload caused the server error.

Was the server accessible before you built the plugins?  Did the entire server become inaccessible, or just FogBugz?
David Fullerton Send private email
Friday, June 19, 2009
Straight after the upgrade the server was fine, and showed that the existing plugins were out of date and needed building.

As soon as I rebuilt those plugins I tried to access FogBugz, but it was un-responsive, kept timing out. I didn't try the web root to see if the entire web server was unresponsive, I just rebooted the machine.

Just in case it's relevant, I had to give myself full access to the Plugins folder as usual, as discussed in
Ian Jones Send private email
Friday, June 19, 2009

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
Powered by FogBugz